Tuxlink

Error/Solución: Pulse Audio en Hardy Heron

Posted on: 6 junio, 2008

No se si alguno de ustedes haya tenido problemas de audio en las aplicaciones multimedia, en mi caso si los hubo, así que me puse a buscar un poco con los síntomas que presentaba mi instalación de Ubuntu 8.04:

  • Solo una aplicación a la vez podía reproducir audio.
  • Los videos de YouTube (y de sitios similares) se atoraban a los 2 segundos, no era el navegador de Internet y lo comprobé.
  • Si había otra aplicación (pj. Bnahsee), los videos no se reproducían en Totem, VLC o cualquier otro.

Tal vez alguno otro, pero esos son los que más recuerdo.
En fin después de un rato de búsqueda encontré que eso ya era cosa de varios usuarios, todo por la introducción del nuevo servidor de sonido Pulse Audio, que originalmente fue desarrollado para Fedora pero se incluyó en esta versión de Ubuntu. Y es que al parecer aun hay varias aplicaciones que no están optimizadas para su correcto funcionamiento con este servidor ya que utilizan ALSA con otros parámetros.

  • Solución

Aunque traté varias cosas antes, los siguientes pasos fueron los que solucionaron el problema:

1. Ve al menú Sistema/Preferencias/Sonido .

Pulse Audio Prefrencias

2. Cambia todas las opciones a Pulse Audio Sound Server, puedes comprobar su correcto funcionamiento dando clic en el botón Probar

3. Ve a la pestaña Sonidos y activa la casilla Activar mezcla de sonido por software (ESD).

Una vez hecho esto todas las aplicaciones deberían de enviar el audio a a dicho servidor, todas excepto flash. Para que este también lo haga debemos tener instalada la librería libflashsupport de la que les hablé en Optmizar flash player.
Para instalarlo abre una Terminal (Aplicaciones/Accesorios/Terminal) y ejecuta:

sudo apt-get install libflashsupport

Como último paso habrá que reiniciar todo el PC, para evitar errores de que no se inicie correctamente el servidor de audio.
Con esto debería de solucionarse el problema de audio en Hardy Heron.
Saludos.

|Vía: biestado

5 comentarios to "Error/Solución: Pulse Audio en Hardy Heron"

gracias por la info me sirvio mucho

Muchas gracias por el tutorial, yo tenia el mismo problema

Saludos

Y yo que pensaba que era el único con este problema. ¡Mil Gracias!

Ese problema me tenía un poco confundido. Muchas gracias!!

Al poner todo con Pulse (paso 2) y probando me da el siguiente error:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Failed to connect: Connection refused
¿alguna sugerencia?

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Tuxlink RSS

Translate (main page)

Download LeopardX

Lectores conectados

website stats

My Flickr Photos

MenuMeters-Bartender

07-exirion-os-mexicano

06.-OptWord-jQueryFooter

Más fotos
A %d blogueros les gusta esto: