Tuxlink

Instalar: Avant Window Navigator (Actualizado)

Posted on: 3 noviembre, 2007

En un post anterior les hablé de Avant Window Navigator y las mejoras que incluía. Leyendo un poco en los tutoriales de Ubuntu forums y el wiki de avant he visto que le podemos dar un look como este:

awn-curves

En la versión más reciente 0.3.1 el efecto curves ya esta incluído y AWN detecta cuando se instala un tema correspondiente a él aplicandolo automáticamente, si tienes una versión anterior de este Dock visita este tutorial en Ubuntu forums para ver los pasos de su instalación.
Pasemos a la instalación de esta nueva versión.

  • Desintstalar AWN previa

Si ya tenías instalada Avant Window Navigator ya sea por paquete *.deb, repositorios o desde el mismo codigo fuente tendrás que desinstalarla, ejecuta en una terminal (Aplicaciones/Accesorios/Terminal):

sudo rm -f /usr/local/bin/awn*
sudo rm -f /usr/local/bin/avant*
sudo rm -rf /usr/local/lib/awn
sudo rm -f /usr/local/share/locale/*/LC_MESSAGES/avant-window-navigator.mo
sudo rm -f /usr/local/share/applications/avant*
sudo rm -f /usr/local/share/applications/awn*
sudo rm -rf /usr/local/share/avant-window-navigator
sudo rm -f /usr/local/lib/libawn*
sudo rm -rf /usr/local/include/libawn
sudo rm -f /usr/local/lib/libawn*
sudo rm -f /usr/local/lib/pkgconfig/awn.pc
sudo rm -rf /usr/local/share/awn-core-applets
sudo rm -rf /usr/local/lib/python2.5/site-packages/awn/

Si la haz instalado por repositorios buscala mediante synaptic y desintslala.

  • Instalación-Avant Window Navigator

Nota: En Ubuntu Hardy ya se cuenta con la versión 0.2.1 en los repositorios oficiales y se puede instalar ejecutando en una Terminal:

sudo apt-get install avant-window-navigator

Si quieres la versión 0.3.1 (la más nueva tengo entendido) puedes añadir los siguientes repositorios, has lo mismo dependiendo de tu versión:

  1. Presiona Alt+F2 y escribe:

    gksudo gedit /etc/apt/sources.list

  2. Dependiendo de tu versión agrega los repositorios a cualquier parte del texto:

    Para Hardy: deb http://ppa.launchpad.net/reacocard-awn/ubuntu hardy main
    deb-src http://ppa.launchpad.net/reacocard-awn/ubuntu hardy main

    Para Gutsy: deb http://ppa.launchpad.net/reacocard-awn/ubuntu/ gutsy main
    deb-src http://ppa.launchpad.net/reacocard-awn/ubuntu/ gutsy main

    Para Festy: deb http://ppa.launchpad.net/reacocard-awn/ubuntu feisty main
    deb-src http://ppa.launchpad.net/reacocard-awn/ubuntu feisty main

  3. Guarda el archivo y cierra el editor de textos.
  4. Actualiza los repositorios:
    sudo apt-get update
    Nota 2: Estos repositorios no tienen una clave de autenticación, por lo que al hacer el paso anterior puede que marque error al momento de comprobarlos.
  5. Por último instalamos Avant Window navigator con:
    sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr awn-manager-bzr
  6. Si no quieres los applets solo ejecuta:
    sudo apt-get install avant-window-navigator-bzr awn-manager-bzr
  • Temas para el efecto Curva

Puedes instalar estos dos temas que son hechos para este efecto:

|Descarga:

Para instalarlos ve a Sistema/Preferencias/Awn Manager y en el panel de la izquierda da clic en themes, después en el botón añadir y elige los archivos que has descargado.

  • Desinstalar AWN

Si quieres desinstalar AWN, que espero que no, buscala mediante Synaptic y marcala para elminar, si la instalaste por codigo fuente y la compilaste ve a la carpeta donde hicste sudo make install y ejecuta sudo make uninstall.

Espero que les guste y les sea de utilidad, estos lanzadores de aplicaciones o dock siempre son buenos.

|Enlace:

|Relacionado:

Última Actualización: 6 de Abril de 2008

53 comentarios to "Instalar: Avant Window Navigator (Actualizado)"

[…] Actualización (2/11/07):Tutorial de como innstalar Avant Window Navigator en Gusty y festy con nuevo efecto aqui. […]

[…] Actualización (2/11/07):Tutorial de como innstalar Avant Window Navigator en Gusty y festy con nuevo efecto aqui. […]

[…] Instalar: Avant Window Navigator en Gusty « Tuxlink on Noviembre 3rd, 2007 […]

hola para hacerlo en kubuntu es el mismo procedimiento o hay que cambiar algo? saludos y gracias!

@gonzalo: Creo yo que serían los repositorios osea lo más importante por que es de donde obtienes todos los paquetes y por lo que he buscado no encuentro información de como instalarla en Gusty, es raro por que los requerimientos serían tener Compiz fusion o beryl instalado.
Seguiré buscando.
Saludos

Recibo errores al intentar ejecutar autogen.sh, terminando con:

Running intltoolize…
intltoolize: ‘po/Makefile.in.in’ is out of date: use ‘–force’ to overwrite

De ahí ya no hace más, y tampoco puedo hacer el make.

¿Es la primera vez que la instalas?, si no es así desinstala la versión que ya tenías y asegurate de tener las dependencias de avant que son las que estan antes de, o tal vez es por que estas haciendo cada comando por separado pero debes de poner todo en una sola línea

Estas son las dependencias:

Copia y pega en una sola línea

sudo apt-get install build-essential autotools-dev libxdamage-dev libxcomposite-dev libgnome2-common libgnome2-dev libgnome-desktop-dev libgnome-vfs-dev libgtk2.0-dev libwnck-dev libgconf2-dev libglib2.0-dev libdbus-glib-1-dev libgnomevfs2-0 libgnome-desktop-2 libgnome2-0 libwnck-common python-gtk2 python-gconf bzr gnome-common python-dev python-gtk2-dev python-cairo-dev python-gconf python-gnome2-dev gnome-icon-theme python-glade2 librsvg2-common, python-gnome2-extras

Copia y pega en una sola línea Instalar awn-curves.

sudo apt-get install build-essential autotools-dev libxdamage-dev libxcomposite-dev libgnome2-common libgnome2-dev libgnome-desktop-dev libgnome-vfs-dev libgtk2.0-dev libwnck-dev libgconf2-dev libglib2.0-dev libdbus-glib-1-dev libgnomevfs2-0 libgnome-desktop-2 libgnome2-0 libwnck-common python-gtk2 python-gconf bzr gnome-common python-dev python-gtk2-dev python-cairo-dev python-gconf python-gnome2-dev
bzr co http://bazaar.launchpad.net/~awn-curves-team/awn/awn-curves awn-curves
cd awn-curves
./autogen.sh && make
sudo make install

Buenas, a mi lo que me pasa es que el comando
sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr
no lo encuentra:
E: Couldn’t find package avant-window-navigator-bzr

Es una instalacion de ubuntu gutzy nueva. Por si a caso habia borrado la AWN previa, pero no chuta. Todo lo anterior lo ha hecho muy bien.
MUchas gracias por el tutorial. De verdad que alucino con lo mucho que sabeis! Y con lo que me ha costado a mi poder instalar el driver de ati!!!

@Lotipep: Eso generalmente pasa cuando no tienes los repositorios añadidos por lo que no puede encontrar el paquete que le estas pidiendo.
Aunque ya los tengas, vuelvelos a añadir, tal vez ahí este el problema:

deb http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator
deb-src http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator

Estos son los de Gusty.
Añade la clave, también puede que haya cambiado,

wget http://download.tuxfamily.org/syzygy42/reacocard.asc
sudo apt-key add reacocard.asc
rm reacocard.asc
sudo apt-get update

Después actualizalos con sudo apt-get update.

No te debe dar ningún error, ni añadiendo repositorios ni cuando bajes la clave de autenticación.

Dlinx, ya lo había desinstalado cuando empecé a probar esto, y lo tengo todo en la misma línea.

La parte de error entera es:

Running glib-gettextize… Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
progtest.m4
from the /aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Running intltoolize…
intltoolize: ‘po/Makefile.in.in’ is out of date: use ‘–force’ to overwrite

Puedo seguir a pesar de esos errores (el error era un error mío), pero al hacer el make install me termina con:

Making install in po
make[1]: se ingresa al directorio `/home/max/awn-curves/po’
make[1]: *** No hay ninguna regla para construir el objetivo `install’. Alto.
make[1]: se sale del directorio `/home/max/awn-curves/po’
make: *** [install-recursive] Error 1

Perdón por la repetición de mensajes, pero terminé borrando todo e iniciando el proceso de instalación de nuevo logré completar la instalación.

Igual ahora no arranca el awn, y si intento iniciarlo desde consola me dice

Screen is composited.
Fallo de segmentación (core dumped)

Y nunca arranca el dock.

Bueno, he conseguido instalarlo, pero no se abre el awn. Despues de reiniciar me salio un error de gnome. He desinstalado el curves, pero sigo sin poder abrir el awn. Bueno, tampoco es grave.

Muchas gracias de todas formas.

Me pasó lo mismo que a ti solamente que yo cuando desinstalé el curves en ese mismo momento si me funcionó.
Hay que recordar que aun esta en fase de desarrollo y no hay ninguna versión estable, aunque si yo lo pude instalar no se por que a ustedes les marcan tantos errores.

Bueno, hoy arranqué mi Ubuntu y la barra funciona a la perfección con el efecto de curva, se ve que el error que me daba, alguna actualización de algo lo solucionó.

Gracias por todo.

Yo tengo un problema q me esat volviendo loco…
“Se utilizarán 101MB de espacio de disco adicional después de desempaquetar.
¿Desea continuar [S/n]? s
Abortado.”

eso me dice cuando intento instalar el awn-curves…

probe con S, s, y, yes, si, no… etc etc… no puedo hacer que me baje, siempre me dice abortado…

alguien sabe cual es el problema???

Hace poco seguí el Tutorial de nuevo para instalarlo en una instalación limpia de Ubuntu, y me encontré con el mismo error que tu, instalando otras aplicaciones también me había pasado. Ya he dividido ese comando en dos partes. Ese es el modo con el que ya puedes instalarlo, primero las dependencias y después descargará el paquete de curves para instalarlo.
Saludos

Saludos a todos tengo un problema cuando pongo esto en la terminal me sale sol siguiente:

bzr co http://bazaar.launchpad.net/~awn-curves-team/awn/awn-curves awn-curves
cd awn-curves
./autogen.sh && make
sudo make install

ricky@ricky-desktop:~$ bzr co http://bazaar.launchpad.net/~awn-curves-team/awn/awn-curves awn-curves
bzr: ERROR: Target directory “awn-curves” already exists.
ricky@ricky-desktop:~$ cd awn-curves
ricky@ricky-desktop:~/awn-curves$ ./autogen.sh && make
bash: ./autogen.sh: No existe el fichero ó directorio
ricky@ricky-desktop:~/awn-curves$ sudo make install

espero me ayuden gracias

Hola buenas:

He seguido todo el procedimiento, sin al parecer problemas de insalacion pero cuando intento ejecutar awn manager no hay respuesta. ¿Alguna idea de lo que puede ocurrir?

Gracias

ay algun plugin o programiya para poder ver en el awn las ventanas como miniaturas de la pagina, no como iconos??? igual que con el de mac??quizas en futuras versiones??

Hola, cuando intento ejecutar awn no hay respuesta.
Help, please..

Gracias

@Alexandre: Sería bueno que ejecutaras en una terminal:
avant-window-navigator
Para ver si devuelve algún error.
Saludos.

Gracias

BUenas….
He estado leyendo bastante el blogsito y mi pregunta es la siguiente…???

Es necesario instalar primero el efecto curva y despues el AWT???

O primero puedo instalar el AWT y luego el efecto??

Saludos,

@Infraga: Avant Window Navigator es independiente del efecto curves, tal vez en futuras versiones se incluya, pero por el momento puedes instalar AWN sin el efcto curves y no habrá mayor problema, en si curves es un simple plugin que cambia el aspecto a AWN.
Saludos.

[…] Instalar Avant Window Navigator en Gusty-Festy […]

[…] Actualización (7/11/07): Instalar Screenlets en Ubuntu- Dashboard. Tutorial aquí. Actualización (2/11/07):Tutorial de como innstalar Avant Window Navigator en Gusty y festy con nuevo efecto aqui. […]

[…] Instalar: Avant Window Navigator en Gutsy […]

Hola!
He intentado hacer lo que dice en este blog, y hasta el momento no he logrado más que un dolor de cabeza.
Agradecería que me puedan ayudar a instalarlo.
Gracias.

arturo01: En que parte del tutorial tienes problemas, la Terminal suele devolver los errores que surgen haciendo posible saber en que estamos mal, si tienes problemas en el procedimiento sería bueno que especificaras en que te da error.
Saludos ñ_ñ.

No te entendi ni mierda ahi dice q desinstalar deberias ser mas especifico para la gente que no ah instalado nada ..

xxx: creo que a alguien no le gsuta leer, el post no puede ser más específico, y está dividido por puntos, como llegaste hasta aquí abajo (los comentrarios) sin pasar por la sección “Instalación-Avant Window Navigator, no puedo hacer más específico. Presiento que vienes de windows por el solo hecho de que estas acostumbrado a instalar las cosas con next next next… creo que deberías de empezar a practicar un poco más la lectura de “seguir instrucciones”.
Saludos ¬¬.

Hola, tengo un problema con la clve de autentificación, aparece un error 404. ¿Cómo lo arreglo? Gracias.

[…] Dock de Mac que estoy usando y como instalarlo en Ubuntu: Avant Window Navigator […]

Saludos.

Recién he instalado Hardy y he tratado de instalar awn-curves siguiendo tus instrucciones, pero no helogrado sino instalar la versión plana. Anteriormente en gutsy lo había logrado,pero ahora no. ¿Podrías ayudarme? Gracias.

AlxTommy: Gracias por visitar el blog. ¿Que versión de AWN instalaste, la que viene en los repositorios oficiales (0.2.1) o la de los repositorios de Launchpad (0.3.1)? A partir de que instalé la 0.3.1 ya no necesité compilar el efecto curves, por que con solo aplicar alguno de los temas que coloqué en esta entrada lo detecta y toma esa forma.
¿Has tratado a aplicar algún tema?
Saludos.

Muchísimas gracias, instalé los temas, como me indicaste, y automáticamente el problema se corrigió. Ahora ya puedo volver a disfrutar esta magnífica aplicación.

Saludos.

P. D. por si a alguien le sirve instalé la versión de repositorios Launchpad (0.3.1)

Gracias tío, gente como tú nos hace la vida más fácil a la gente que empezamos pero no queremos renunciar a estos detalles.

[…] Instalar: Avant Window Navigator en Gutsy […]

Wenas, me parece un buen tutorial. Bueno llevo unos dias pegandome con unos cuantos y todo se instala bien pero al ejecutarlo me da error. Tengo un Kubuntu Hardy. Con anterioridad me funciono muy bien en gusty. El error es el siguiente:
** (avant-window-navigator:9459): WARNING **: Failed to make connection to session bus: Failed to execute dbus-launch to autolaunch D-Bus session

** (avant-window-navigator:9459): CRITICAL **: dbus_g_proxy_new_for_name: assertion `connection != NULL’ failed

** (avant-window-navigator:9459): CRITICAL **: dbus_g_proxy_call: assertion `DBUS_IS_G_PROXY (proxy)’ failed

** (avant-window-navigator:9459): WARNING **: There was an error requesting the name:
Fallo de segmentación

Muchas gracias.

[…] : Ubuntu 7.10 Gutsy : Corn Field : fue personalizado con GNOME Color Chooser (Del que les hablaré en unos post más adelante). : Human. : Human metacity. : Avant-Window-Navigator […]

@Indglor: yo tambien tengo el mismo problema😦
avant-window-navigator:14301: WARNING **: Failed to make connection
alguna solucion alguien?

No se si han instalado la versión de estos repositorios o la que vine en los repositorios oficiales de Ubuntu, de cualquier manera y leyendo un poco encontré que en algunas ocasiones no se instala el paquete dbus-x11, y como el error que tienen es relacionado a dbus no se si ese paquete llegara a solucionar el error. En este momento no uso Ubuntu y no puedo revisar si está en lso repositorios, pero prueben a instalarlo a ver que pasa.
Un saludo.
Más información en el wiki de AWN:
http://wiki.awn-project.org/DistributionGuides#Hardy_Heron_.288.0x.29_and_later
http://wiki.awn-project.org/DistributionGuides#Hardy_Heron_.288.0x.29_and_later

[…] Actualización (7/11/07): Instalar Screenlets en Ubuntu- Dashboard. Tutorial aquí. Actualización (2/11/07):Tutorial de como innstalar Avant Window Navigator en Gusty y festy con nuevo efecto aqui. […]

Waa lo voy a desinstalar! nada, ya llevo mas de un mes peleándome con el programa y nada!, parese que esta muy bien instalado y todo, pero la barra nunca que aparece!😦

stencer: Si no tienes aceleració gráfica de tu tarjeta de video, pero aun más importante, un gestor de ventanas como compiz, beryl o el composite manager de gnome la barra nunca aparecerá.
Para ver si devuelve errores al ejecutarse, lanza la aplicación desde la terminal con el comando:
avant-window-navigator
Saludos.

Seguí las indicaciones que das y todo funcionaba a la perfección, incluso los temas y el efecto curva. El caso es que el otro día actualicé algunos paquetes del sistema (típicas actualizaciones que te ofrece ubuntu) y entre ellos estaba el awn. Los applets me siguen apareciendo, pero ni los Launchers, ni las ventanas abiertas se encuentran en la barra. Agradezco una posible solución y por supuesto tu artículo que está muy claro y fácil de seguir. Un saludo.

perezxavi: Creo yo que se te han borrado los archivos de configuración de AWN. Has probado a volver a configurar algunas cosas como por ejemplo volver a habilitar la función de mostrar las aplicaciones en la barra y en cuanto a los launchers, ¿no se si en las preferencias de AWN te sigan apareciendo?.
Esto es prácticamente un error de la actualización y creo que la única slución sería confgurarla de nuevo.
Saludos.

yo desisti tambien de poder usarlo luego de como 1 semana de probar y probar, ya fue suficiente😥

Muchas gracias por los comentearios y en especial a Eduardo. Efectivamente es el paquete dbus-x11 el culpable de todos mis quebraderos de cabeza. Aquellos que tenian el mismo error que yo que se insatelen el dbus-x11 y se soluciona.

Los links de “Temas para el efecto Curva” ya ninguno esta disponible, podrias corregirlos y/o darnos algunos nuevos.

De antemano
Gracias!!

Hola, Porfavor alguien sabe como instalarlo para Jaunty?
Si, es así porfavor agregame al msn ermejor_hk@hotmail.com
Muchas gracias.

[…] Instalar Avant Window Navigator en Gusty-Festy […]

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Tuxlink RSS

Translate (main page)

Download LeopardX

Lectores conectados

website stats

My Flickr Photos

MenuMeters-Bartender

07-exirion-os-mexicano

06.-OptWord-jQueryFooter

Más fotos
A %d blogueros les gusta esto: